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Ten Tips for
Creating Usable and
Accessible PDFs
Posted on December 2, 2008 by Deborah Edwards-Onoro

When I started my new job earlier this year, one of
my first tasks was to identify methods for creating
usable and accessible Adobe Acrobat PDF files.
Eight months later, I’m still learning new techniques
and sharing them with other web workers.

From the local USTA tennis district office to ebook
publishers to fellow college web workers, I’ve
shared my process for improving the usability and
accessibililty of PDF files.

With the hopes that what I’ve learned will help
others who publish PDF files, I’ve highlighted ten
tips I use for creating accessible and usable PDF
files. Not intended to be an extensive how-to
tutorial, the tips I’ve outlined here will get you
started in the right direction for creating friendly
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PDFs from Microsoft Word and Adobe InDesign.

The article focuses on document preparation
before the PDF is created, as well as processing
the PDF further in either the full version of Acrobat
8 or Acrobat 9. There’s not a lot of information on
managing tables or forms in PDF files, just some
basic advice to move you toward creating a better
PDF experience for your users.

I’m hoping the article will encourage further
discussion, but hope the discussion doesn’t head
in the “PDF sucks” debate. While it’s a valid
debate, my interest in publishing this article is to
provide tips and suggestions for those web
workers looking for solutions in creating usable
and accessible PDF files. There’s a list of
resources at the end of the article for additional
information about PDF files.

1. Use a structured source document
A properly structured source document is
key to creating an accessible PDF file and
essential to meeting Section 508
compliance in the United States. The
structure within the source document allows
PDF files be tagged, which means it has a
logical defined order. Headings, tables,
images, and paragraphs in a tagged PDF
file can be easily identified by the user. A
tagged PDF file also contains information
about its reading order.

To add structure:
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In Microsoft Word, use Word styles to format
text. For example, use styles to create
headings (Heading 1, Heading 2, etc.),
rather than selecting text and making it
bold. Add ALT text to all images so text can
be read aloud by screen readers. Use
“Insert Table” to create a table rather than
using tabs and spacing to layout a table.
Check Andrew Kirkpatrick’s (Adobe’s Senior
Product Manager for Accessibility) excellent
Reference Card for Accessible PDF
Creation from Word for detailed tips on
styling Word documents.

In Adobe InDesign, several methods can be
used to structure a document, including
manually tagging content, deriving structure
from styles, and mapping styles to specific
tags. To view the structure of a document,
select View > Structure. Mark and hide
printing artifacts, text and content so they
won’t display when the PDF document is
reflowed for a different display, such as a
mobile phone or large monitor.

Check Andrew Kirkpatrick’s Accessibility
and Adobe InDesign CS3 (PDF) for further
details on adding structure.

As with Microsoft Word, ensure all images
have ALT text. Adobe’s InDesign CS4
Accessibility Overview has additional
information on InDesign’s accessibility.

2. Save/export document as tagged PDF
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In Microsoft Word, assuming Adobe Acrobat
has been installed on the same computer,
Adobe adds an additional option in the
Word ribbon/menu bar for its PDF Maker
plugin to create PDF files. The PDF Maker
plugin has numerous conversion settings for
accessible documents.

In Word 2007, the Acrobat option is added
to the ribbon; in Word 2003, the Adobe PDF
option is added to the menu bar. Again,
check Andrew Kirkpatrick’s Reference Card
for Accessible PDF Creation from Word for
detailed information on the conversion
settings for Word 2003 and Word 2007.

Note for Macintosh users: PDF Maker is not
available in Word 2008, and conversion
settings in Word 2004 are not the same as
the Windows Word version. From my own
personal experience, creating tagged PDF
files in Macintosh Word is problematic.

To modify the PDF Maker conversion
settings, select either Acrobat or Adobe
PDF from the Word ribbon/menu bar. In
Word 2007, select Preferences from the
Create Adobe PDF group. In Word 2003,
select Adobe PDF, and select Change
Conversion Settings.

The instructions below assume Acrobat 8 or
higher version has been installed; note that
Acrobat 7 does not have the same
advanced conversion setting options.

http://blogs.adobe.com/accessibility/2008/03/reference_card_for_accessible.html
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Here’s a quick list of the conversion settings
to change in the PDF Maker:

A. In the Settings tab, enable:
i. Fully functional PDF
ii. Add Bookmarks to Adobe PDF
iii. Add Links to Adobe PDF
iv. Enable Accessibility and Reflow with

tagged Adobe PDF
B. In the Security tab, if security

permissions are enabled
i. Enable text access for screen reader

devices for the visually impaired
C. In the Word tab, enable:

i. Convert cross-references and table of
contents to links

ii. Convert footnote and endnote links
iii. Enable advanced tagging

D. In the Bookmarks tab, enable:
i. Convert Word Headings to

Bookmarks
Select OK to save the settings. In Word
2007, select Create PDF from the Create
Adobe PDF group. In Word 2003, select
Convert to Adobe PDF from Adobe PDF,
and save the document.

You can also use the Adobe PDF icon that
appears in the Quick Access Toolbar in
Word 2007 and in the Word 2003 menu bar
to quickly save a document as a tagged
PDF file. If you use the icon, ensure that all
your conversion settings have been
modified, or the document will not be saved
as a tagged PDF file.
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Note: Print to PDF in Word does not
produce a tagged PDF file; it strips out all
tagging.

In InDesign, select File > Export > Save as
Type > Adobe PDF. The Export Adobe
PDF dialog box will display, with seven
panel options in the left column. Here’s a list
of the settings to change in the Export
Adobe PDF dialog box:

A. In the Compatibiity panel, select
Acrobat 7 (PDF 1.6)

B. Select the Options panel, enable:
i. Optimize for Fast Web View –

organizes PDF information so the first
pages of a PDF file can be viewed
while the remaining document is
downloaded

ii. Create Tagged PDF
iii. View PDF after Exporting

C. Select the Include panel, enable:
i. Bookmarks
ii. Hyperlinks

D. Select the Output panel to change the
color space for screen display
i. In the Color Conversion drop-down

menu, select Convert to Destination
(converts the colors to the destination
specified in step 2)

ii. Change Destination option to sRGB
IEC61966-2.1, which allows non-
Acrobat applications to open the PDF
file and ensure colors look good
without color management.
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According to InDesign CS4 One-on-
one, the sRGB color space is the best
color space for identifying a computer
monitor’s display capabilities.

iii. Change Profile Inclusion Policy to
Include Destination Profile so the
color profile is embedded in the PDF
file

E. Select Export
For applications that produce untagged
PDF files, tags can be added automatically
in a full version of Acrobat (Advanced >
Accessibility > Add tags to document)
after a PDF has been created. Be aware that
using Add tags to document will remove any
existing tags in the PDF file. Also, as of
November 2008, documents created in
Quark cannot be saved as tagged PDFs;
tags will need to be added.

For PDFs created from scanning images, in
a full version of Adobe Acrobat select
Document > OCR Text Recognition >
Recognize Text Using OCR and then add
tags using a full version of Acrobat.

In the last few months, I’ve discovered two
word processing applications that create
tagged PDF files: NeoOffice and the newest
version (as of October 2008) of OpenOffice.
I have not used either of these applications.
Perhaps someone who has created a
tagged PDF from NeoOffice or OpenOffice
can comment on the results?

http://safari.oreilly.com/9780596156497/exporting_to_pdf
http://www.neooffice.org/
http://www.openoffice.org/
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To check if a PDF file is tagged, open the
document in Adobe Acrobat or Adobe
Acrobat Reader. Select File > Properties >
Description. Check that the Tagged PDF
option in the Advanced pane is enabled.

The following steps, steps 3 to 8, are
completed in a full version of Adobe
Acrobat; Adobe Acrobat Reader cannot be
used.

3. Add title, author, subject and keywords
Make it easy for users to know what the PDF
file is about and who or what organization
authored the file. Be aware the title is almost
always displayed in search engine results.

Select File > Properties > Description

A. Title – add a meaningful title
B. Author – brand your PDF file with

author/organization name
C. Subject – what the document is about
D. Keywords – keywords for the document
E. Select OK
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4. Add bookmarks
Bookmarks act as a table of contents in a
PDF file, allowing users to quickly navigate a
PDF. Who has time to scroll through 36
pages in a PDF file to find chapter 3? For
PDF files larger than two pages, add
bookmarks to the file.

If you followed step 2 (save/export
document as tagged PDF) bookmarks will
automatically be created from the source
document. If the Word source document
contained a table of contents, the table of
contents will display in the Bookmarks pane.

To create bookmarks, open the Bookmark
Panel (View > Navigation Panels >
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Bookmarks or select the Bookmark icon in
the navigation pane). Use one of the
following methods:

A. Add bookmarks based on document
structure – the easiest method!
i. If the PDF file is tagged, you’re in

luck! Use the structure to create the
bookmarks automatically

ii. In the Bookmark pane, select the
Options menu

iii. Choose New Bookmarks from
Structure

iv. The Structure Element dialog box
displays – select the elements you
want to convert

v. Select OK
B. Create bookmarks from selected text in

the PDF file
i. Use the Select tool from the Select

and Zoom toolbar
ii. Select text you want for the bookmark
iii. Select the New Bookmark icon on

the Bookmarks pane toolbar or in the
Options menu, select New
Bookmark to add the text

C. Add blank bookmarks and fill them in
manually – most time consuming
i. In the existing bookmarks, click the

location above where you want to add
a new bookmark

ii. Select the New Bookmark icon on
the Bookmarks pane toolbar or in the
Options menu, select New
Bookmark
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iii. The bookmark will be created with the
default text “Untitled”

iv. Enter the text for the bookmark
5. Initial view

When the PDF file is opened, display the
title of the PDF file in the title bar and the
bookmark panel in the navigation pane.

Titles such as htraindal.doc aren’t very
descriptive to users compared to “How to
Train Your Dalmatian”. Having the PDF open
with the bookmarks visible gives the user a
quick summary of the contents of a PDF.
Otherwise the user won’t know that
bookmarks exist!

Select File > Properties > Initial View

A. In the Layout and Magnification section
i. In the Navigation tab, select

Bookmarks Panel and Page
ii. In Page layout, select Default
iii. In Magnification, select Default
iv. In Open to page, select 1

B. In the Windows Options section
i. Keep all checkboxes unchecked
ii. In Show: select Document Title

C. In the User Interface Options section,
uncheck all checkboxes

D. Select OK



5/3/2014 Ten Tips for Creating Usable and Accessible PDFs | Refresh Detroit

http://refreshdetroit.org/ten-tips-for-creating-usable-and-accessible-pdfs/ 12/21

6. Specify the reading language
Set the document language so screen
readers can switch to the appropriate
language for the user.

Select File > Properties > Advanced

A. In the Reading Options section, for the
Language option, select the appropriate
language from the menu.

B. Select OK
7. Correct the reading order

For each page, the reading order defines
how the content is read on that page. To
view the reading order for a specific page,
select Advanced > Accessibility >
TouchUp Reading Order.
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The TouchUp Reading Order dialog box
displays, with gray numbered boxes
surrounding content. The numbers on each
box indicate the order in which the content
will be read. If the order is not what you
expect, or you need to modify figure or table
tags, or add alternate text descriptions to
images, use the TouchUp Reading Order
tool.

If numbered boxes don’t appear when the
TouchUp Reading Order dialog box is open,
the PDF file is likely not tagged. More
information on TouchUp Reading Order and
how to change/edit order can be found at
WebAIM.

8. Use PDF Optimizer
The PDF Optimizer provides many settings
for reducing the file size of the PDF file;
downsizing graphics, discarding objects,
cleaning up settings are just a few of the
settings.

Creating an accessible PDF file with a small
file size can be challenging, since adding
accessible features to a PDF file increases
the file size. Below are the settings I use to
optimize PDF files; creating a custom setting
in the PDF Optimizer that fits your
requirements may be the best solution.

Select Advanced > PDF Optimizer

A. Enable the following sections

http://www.webaim.org/techniques/acrobat/acrobat.php#touchup
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i. Images
ii. Fonts
iii. Discard Objects
iv. Discard User Data
v. Clean Up

B. In the Make Compatible with section,
change compatibility to Acrobat 7

C. In the Images section, for Color Images
and Grayscale Images
i. Change the compression to

JPEG2000 (available to any user with
Acrobat 7 or Acrobat Reader 7
version or above)

ii. Set quality to medium. To avoid text
and image blurring, set the quality to
lossless for screen shots and
manuals

iii. Change Downsample pixels/inch to
96 pixels/inch for any image over 100
pixels/inch

D. In the Discard Objects section
i. Enable Discard all alternate images
ii. Enable Detect and merge image

fragments
iii. Enable Discard embedded page

thumbnails (newer Reader versions
can create thumbnails on the fly)

iv. Enable Discard embedded print
settings

v. All other settings should be disabled
E. In the Discard User Data section,

enable all settings except Discard
document information and metadata

F. In the CleanUp section, enable all the
checkbox settings
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G. In the Object compression options,
select Compress entire file

H. Select OK

Once you have configured the optimization
settings, you don’t have to type them in for
each PDF file. Use the Save button to save
your custom configuration so you can use it
for the next PDF file.

9. Enable Adobe Reader features
Users often want to add comments to PDF
files. Enabling Adobe Reader features
allows Adobe Reader users to add
comments, as well as fill in form fields,
without having to purchase the full Acrobat
product.

Select Advanced > Enable Usage Rights
and select Save Now

Note: enabling Adobe Reader features
restricts editing content as well as inserting
and deleting pages in the PDF file.
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10. Check accessibility
You’ve followed the steps to create a PDF
file, but how do you know if the file is
accessible, or if you have some additional
changes to make?

Select Advanced > Accessibility > Quick
Check to see if the PDF is tagged. For more
information, select Advanced >
Accessibility > Full Check for a detailed
report on what is missing in the PDF as well
as recommended changes to the PDF file
such as adding ALT text to images, tagging
headings, etc.

Phew! That’s it. These ten tips will get you started
on providing your users with a friendly PDF file that
is easier to use. Automate the steps I’ve described
above using batch processing in Acrobat (video)
to make creating friendly PDFs even easier. Check
out the resources for additional information on
accessible and usable PDFs, including guides and
tutorials.

My gratitude and thanks to Donna Baker, Bevi
Chagnon from Community MX, and the helpful
forum members and Adobe consultants at Acrobat
Users for their patience in answering my ignorant
questions about PDF files.

Shout out to Paul Bukhovko for his Belorussian
translation of this article.

Resources

http://www.acrobatusers.com/tutorials/2008/06/a9video_using_batch_processing_for_tasks/
http://www.donnabaker.ca/
http://www.communitymx.com/
http://www.acrobatusers.com/
http://www.moneyaisle.com/worldwide/ten-tips-reader-be
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Reference Card for Accessible PDF
Creation from Word from Andrew Kirkpatrick
WebAIM PDF Accessiblity – comprehensive
PDF accessibility guide from Web
Accessibility in Mind
Adobe InDesign CS4 One-on-one – new
book on InDesign CS4
Adobe Accessibility – accessibility
information on all Adobe products
AcrobatUsers – articles, tutorials, and
forums on all things Acrobat related
Facts and Opinions on PDF Accessibility by
Joe Clark
Why PDFs Suck by Henny Swan, Web
Access Centre, Royal National Institute of
Blind People
Creating Accessible PDFs (PDF, 859K) by
High Tech Center Training Unit, California
Community Colleges
Accessing PDF Documents with Assistive
Technology: A Screen Reader User’s Guide
(PDF, 368K) – Adobe’s guide for using
Acrobat Reader with Screen Readers

Deborah Edwards-Onoro is a web analyst at a
community college, owner of Lireo Designs, a web
development and consulting company, events
officer for Michigan Usability Professionals’
Association and leader of Refresh Detroit.

http://blogs.adobe.com/accessibility/2008/03/reference_card_for_accessible.html
http://www.webaim.org/techniques/acrobat
http://safari.oreilly.com/9780596156497/exporting_to_pdf
http://www.adobe.com/accessibility/
http://www.acrobatusers.com/
http://www.alistapart.com/articles/pdf_accessibility
http://www.rnib.org.uk/wacblog/pdf/why-pdfs-suck/
http://www.htctu.net/trainings/manuals/web/CreatingAccessibleAA8.pdf
http://www.adobe.com/accessibility/pdfs/accessing-pdf-sr.pdf
http://twitter.com/home?status=Check+out+how+to+create+accessible+pdfs+http://bit.ly/Ghou
http://www.lireo.com/
http://www.miupa.org/
http://www.refreshdetroit.org/
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← November 19 Accessibility
Meeting Recap

Tracking outgoing clicks with
Google Analytics →

13 thoughts on “Ten Tips for Creating
Usable and Accessible PDFs”

Pingback: nortypig » Blog Archive » Usable &
Accessible PDFs

This entry was posted in Articles. Bookmark the permalink.

Cathy McAdam says:
December 8, 2008 at 6:45 PM

Thank you for this detailed article.
As a blind user I will be forwarding it to many
PDF creators who still are struggling with
creating accessible documents.

Deborah says:
December 9, 2008 at 7:45 AM

Cathy,

Thanks – creating accessible PDF files has
been a learning experience for me. Glad to
share my experience with others, and hope
the tips help.

http://refreshdetroit.org/november-19-accessibility-meeting-recap/
http://refreshdetroit.org/tracking-outgoing-clicks-with-google-analytics/
http://nortypig.com/2008/12/11/usable-accessible-pdfs/
http://refreshdetroit.org/category/articles/
http://refreshdetroit.org/ten-tips-for-creating-usable-and-accessible-pdfs/
http://www.diverseability.com/
http://www.lireo.com/
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Pingback: Ten Helpful Tips For Creating Usable and
Accessible PDFs | 4xPDF

Pingback: Keep those PDFs accessible and usable! -
STC AccessAbility SIG

Pingback: Top Ten Blog Tips » 10 misconceptions about
web accessibility

Floating Nets says:
January 16, 2009 at 5:46 PM

This will be so useful for transcripting
podcasts to PDF, thanks so much! I even
bookmarked this post as it has so much
information.

A_Flama says:
March 2, 2009 at 4:02 PM

Great tip! thanks 

Deborah says:
March 29, 2009 at 8:10 AM

For an in-depth article that goes beyond the
ten tips for creating accessible PDF files,
check out No Fuss Accessibility article by
Antonio DaSilva.

http://www.pdfpdfpdfpdf.com/2008/12/ten-helpful-tips-for-creating-usable-and-accessible-pdfs/
http://www.stc-access.org/2008/12/26/keep-those-pdfs-accessible-and-usable/
http://www.toptenblogtips.com/10-misconceptions-about-web-accessibility/
http://www.floatingnets.com/
http://www.etrecos.com/
http://www.lireo.com/
http://www.writersua.com/articles/accessibility/index.html
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Pingback: 10 Tips to Help You Create Accessible PDFs in
Word or InDesign

Claude Almansi says:
September 17, 2009 at 8:53 AM

Re using NeoOffice: I’ve done several PDF’s
with it, though I am afraid not using the
advanced settings for the export. However, if I
remember correctly, they are very similar to
the ones you describe for Word.

The problem with NeoOffice (and probably
OpenOffice, on which NO is based) is getting
a TOC where the items link to the various
parts in the source document for the PDF:
possible, but not default (as with Word) and
not very intuitive: I reuse a document where I
managed to do it when I need to have this
feature.

Example of one such PDF I did this way
(using header styles but not the advanced
settings for export) with NeoOffice
http://ia301533.us.archive.org/0/items/Theatre
OfSleep/theatre_of_sleep_03.pdf . A blind
friend told me it was usable for him. But it is a
simple document: no tables, no illustrations.

Sven-Olav says:
October 31, 2009 at 1:59 AM

Thanks Deborah for the great article!

http://blogs.uci.edu/dscatit/blog/2009/10/21/10-tips-to-help-you-create-accessible-pdfs-in-word-or-indesign/
http://www.webmultimediale.org/almansi
http://ia301533.us.archive.org/0/items/TheatreOfSleep/theatre_of_sleep_03.pdf
http://destinator.grifir.com/
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Pingback: The Two Percent

Comments are closed.

Proudly powered by WordPress | Theme: Able by Automattic.

Concerning accessible PDFs, I would like to
suggest the possibility for a user to access
the PDF from web by using named
destinations. IMHO, too few PDF authors are
using named destinations at all, even if the
source document is well structured.

I think the main reason is because there is no
way to export named destinations directly
from MS Word (as it is possible from OO).

I created the plug-in for Acrobat that converts
PDF document bookmarks to PDF named
destinations. I’m hoping that this will make life
easier for many students, professors, and
researchers, especially who are using Mac.
Under Mac OS X there are few (even
commercial) alternatives to automatically
create named destinations.

My Acrobat plug-in is free for academic use:
http://destinator.grifir.com/educational-
license.html

http://www.thetwopercent.co.uk/blog/index.php/2010/03/how-to-make-better-and-accessible-pdfs/
http://wordpress.org/
http://automattic.com/
http://destinator.grifir.com/educational-license.html

